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Introduction 
 

This user guide is intended for HP-UX developers. It helps you use the Eclipse Integrated 

Development Environment (IDE) on your desktop for development on the remote server. 

A sample ñCarò application is used as an example to demonstrate the features in this 

document; you can use the sample car application as part of your development 

environment in Eclipse (The Car application is packaged with the plug-in and is located at 
<ECLIPSE_HOME>\ plugins \ com.hp.cdt.remote.doc.user_ 3. 0.0 \ getting_started

\ Car.zip  -  <ECLIPSE_HOME> is the path where eclipse is installed. This sample project has 

been moved to the remote HP-UX machine and unzipped).  

How to use this guide? 

 

Table 1 lists the layout of the user guide. You can move across sections or follow the 

order described in the document.  
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What is HP-UX Development Environment for 
Eclipse (HP-UX DEE)? 
 

Eclipse is an open source Integrated Development Environment (IDE) that enables a 

software development environment. The IDE allows new extensions, which cater to tools 

and solutions for various development; these extensions are called plug-ins.  

 

The HP-UX Development Environment for Eclipse (HP-UX DEE) allows you to use the 

Linux or Microsoft Windows desktop with Eclipse running on it, while performing the 

C/C++ source code edits, compilations, debugging, running, and static analysis remotely 

on the HP-UX server. Figure 1 shows the Eclipse IDE with the remote development on 

an HP-UX system. 

 

If you currently use a command line in HP-UX as a development environment, an IDE 

such as Eclipse can help improve the productivity by providing easy access to HP-UX 

development tools in a single interface.   

 

 
Figure 1: Remote Developer Plug-in 
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Getting Started with Eclipse 
 

This section describes how to create projects in Eclipse. It addresses the following topics: 

 

¶ Prerequisites 

¶ Creating a new C/C++ project 

¶ Building the project 

 

Prerequisites 

Before creating a project, you must configure your desktop and the HP remote server 

with the required software. For instructions on configuring your desktop, see the HP-UX 

Development Environment for Eclipse Installation Guide present in our main webpage 

(http://www.hp.com/go/eclipse-remotedevplugin).  

Creating a New C/C++ Project 

 

To create a new C/C++ project, click Window > Open Perspective > C/C++. 

Note: If the C/C++ Perspective is not listed, select Other... and select it from the Select       

Perspective dialog box. 

 

Figure 2: Opening a C/C++ Perspective 

http://www.hp.com/go/eclipse-remotedevplugin
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C/C++ Perspective 

Figure 3 shows the C/C++ perspective. The C/C++ Projects Explorer view is to the left of 

the screen. The Outline view is on the right. The center area is reserved for your Edit  

view. There may be other views available in your workbench, such as the Navigator or 

Make Targets views. 

 

Figure 3: C/C++ Perspective  

Project 

Explorer View 
Editor space 

Outline 

View 

Make Target 

View 



              © Copyright 2010 Hewlett-Packard Development Company, L.P.                              

 

8 

Creating a Remote C/C++ Project 

To create a Remote C/C++ project: 

1. Click File > New > Project. 

 

 

          Figure 4: Select Remote Standard Make C/C++ Project 

 

2. In the New Project wizard, expand C/C++ Remote Development and select 

Remote Standard Make C++ project. 
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3. In the Project Name box, type a name for your project.  

4. In the Location box, type the network mounted drive directory path.  

For systems running Windows, it is the CIFS (Samba) mounted drive path, as 

shown in Figure 5. For systems running Linux, use the NFS (or) CIFS mounted 

drive path. 

5. Click Next. 

Note: For information on drive directory path, see the HP-UX Development Environment 

for Eclipse Installation Guide present in our main webpage 

(http://www.hp.com/go/eclipse-remotedevplugin)  

 

Figure 5: Remote Standard C++ Make project wizard  

http://www.hp.com/go/eclipse-remotedevplugin
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Project References 

This page is where you would select other referenced C/C++ projects, if any.  

 
 

     Figure 6: Remote Standard C/C++ Make Project Settings-Referenced Projects 
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Environment Settings 

To set the environment for your project, click the Environment tab. You can add a new 

environment variable or edit an existing variable on the remote system.  

Make Builder Settings 

Click the Make Builder  tab to view its settings. If your build environment has a build 

command that is not of Make type, change your Build Command from the default 

setting. To change the default setting, deselect the Use default check box and type the 

build command in the text box. 

Error Parsers 

To select the Error Parsers for your project, click the Error Parsers tab. You can also 

change the order in which Error Parsers are called. By default, all HP parsers are selected. 

Binary Parser Settings 

To select and set binary parsers for your project, click the Binary Parser tab.  

It is important that you choose the required parser settings to ensure accuracy of the 

C/C++ Projects view and the ability to successfully run and debug your programs. After 

you select the correct parser for your development environment and build your project, 

you can view the symbols of the .o  file in the C/C++ Projects view. 

Discovery Options 

To define the configuration for auto discovery of include  paths and preprocessor 

symbols for the parser, click the Discovery Options tab. The configuration of paths and 

symbols enables the parser to understand the contents of the C/C++ source code so that 

you can use the search and code completion features effectively.   

To configure the scanner discovery to run automatically, select the Automate discovery 

of paths and symbols check box. 

C/C++ Indexer 

To enable or disable the C/C++ Indexer, click the C/C++ Indexer tab. The indexer is 

important for features such as search, content assist, and refactoring. While there may be 

situations where the indexer is not required, for this project you can leave it disabled. 
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HP Code Advisor 

To configure and use the HP Code Advisor plug-in, click the HP Code Advisor tab. By 

default, the Code Advisor location is /opt/c advise/bin/cadvise . If HP Code 

Advisor is installed in a different location, change the value here.  

 

   Figure 7: Remote Standard C/C++ Make Project Settings-HP Code Advisor 

 

 

After setting your C/C++ project preferences, click Next.  

Remote System Configuration 

 

To configure the remote system: 

 

1. In the Hostname, Username, Source Directory, and Display IP Address box, 

type the respective value.  

2. In the PDB Location box, type the location of the Program Database (PDB) 

directory on the remote HP server (if you know the PDB location). If you do not 
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know the location, leave the box empty; this can be changed later from the Project 

Settings page. For information about creating PDB, see: 

http://www.docs.hp.com/en/14242/Cadvise_User_Guide/Cadvise_User_Guide.ht

m#pdb 

 

 
 

Figure 8: Remote System Configuration Page 

 

The description of each box in the Remote System Configuration page is as follows: 

 

¶ Hostname: Hostname of the remote HP-UX system. 

¶ Username: Username on the remote HP-UX system. 

¶ Source Directory: UNIX path of the source location on the remote system. 

¶ Display IP Address: Your local desktop IP address. 

¶ PDB Location: UNIX path of the PDB location stored in the remote 

system. This is required only if you are using HP Code Advisor. 

 

3.  To check if the remote connection is successful, click Test Connection. 

 

 

If the remote connection is successful, a message box appears.  

 

http://www.docs.hp.com/en/14242/Cadvise_User_Guide/Cadvise_User_Guide.htm#pdb
http://www.docs.hp.com/en/14242/Cadvise_User_Guide/Cadvise_User_Guide.htm#pdb
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Figure 9: Successful test connection 

 

If the remote connection is not successful, verify the details provided in the Remote 

System Configuration page and correct them. 

 

To create your project, click Finish. If a message box prompts you to switch perspectives, 

click Yes. 

 

If you only want to view the HP Code Advisor reports, see What is HP Code Advisor?  
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Viewing Projects 

All projects are displayed in the C/C++ Projects view. 

 

             Figure 10: Remote Standard C/C++ Make Project View 

Project Explorer 

Console View 

Outline View 
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Creating a new C++ file 

To create a new C++ source file:  

1. Click File > New > Source File. 

2. Type hello.cpp  in the Source File box. 

3. Click Finish. 

  

 

        Figure 11: New Remote C/C++ Source File 
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Viewing the new project file 

The hello.cpp  file is listed under projects in the Projects view.  

On selecting this file, it opens in the Editor  view. You can now type the code in the 

hello.cpp  file. To expand the view, double-click the hello.cpp  tab in the Editor 

view.  

 

   Figure 12: Writing Codes using the Editor  
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Building the Project 

To save and build the hello.cpp  file: 

1. Press CTRL+S.  

2. Add the file to your Makefile. 

3. To build your project, do one of the following: 

o Press CTRL+B . 

o Select Project->Build .  

The build diagnostics will be listed in the Console view. If there are any errors in the 

code, you can review them in the Problems view. You must determine the reason for any 

build failure from the messages displayed and resolve them accordingly.  

For example: 

If the build fails due to the environment variable not being set, set the environment 

variable. To specify environment variables, see Environment Settings.  

If the following failure message is displayed: Make: Cannot load aCC. Stop. 

1. Set the aCC path for your project.  

2. Click Project Properties > C/C++ Make Project > Environment.  

The list of environment variables appears.  

3. Edit the PATH environment variable and set the aCC path. 
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          Figure 13: Build Remote Standard C/C++ Make Project 

 

 

What is HP Code Advisor?   

HP Code Advisor is a static analysis tool for C and C++ programs. HP Code Advisor 

reports various programming errors in the source code. It is invoked by the cadvise  

command, which can be easily integrated with makefiles or build scripts of the project. 

The result of the cadvise  analysis on the project is stored in a program database (PDB) 

using the - pdb  option. The PDB is a repository of errors, warnings, diagnostic messages, 

and metrics collected by HP Code Advisor while analyzing the application. The PDB can 

be viewed in Eclipse for easy navigation of the diagnostics and sources. Creating the PDB 

is important for viewing code advisor reports of the project in Eclipse. 

For information on creating PDB, see Program Database (PDB) in the HP Code Advisor 

Userôs Guide.   

Once the PDB directory is created on the HP remote server (within the remote project), 

the HP-UX DEE plug-in can be used to view the HP Code Advisor diagnostics.  

The HP-UX DEE plug-in generates a report from the PDB directory and opens it in 

Eclipse.  

Console View shows 

make file output 
Problems View will show 

errors and warnings from 
compilation. 

http://www.docs.hp.com/en/14242/Cadvise_User_Guide/Cadvise_User_Guide.htm#pdb
http://www.docs.hp.com/en/14242/Cadvise_User_Guide/Cadvise_User_Guide.htm
http://www.docs.hp.com/en/14242/Cadvise_User_Guide/Cadvise_User_Guide.htm
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For information on setting the PDB location in Eclipse, see the Project settings for Code 

Advisor.  

Viewing HP Code Advisor Reports in Eclipse 

Once code advisor settings have been completed, select the remote project in Eclipse for 

which the PDB has been created in the remote HP server.  

 

To generate reports: 

1. Right-click the project in the Project Explorer view.  

2. Click HP Code Advisor > Generate Reports. 

  

 
 

Figure 14: Generate Reports Menu 

 

Once the reports are generated from the PDB, two views open in Eclipse: File Summary 

and Summary view. The default view is Summary view.  
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Figure 15: File Summary and Summary Views 

 

To open a new view with the records of that particular diagnostic number, double-click 

any row in the Summary View.  

 

Double Click 
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Figure 16: Source Code 

 

To open the File Summary view, click the File Summary tab.  

 

 
 

Figure 17: Opening File Summary View 

Diagnostic Message 

Error/Warning in Line 

Double Click 

New View opened with Diag # 
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To open a new view with the records of a particular file, double-click any row in the File 

Summary View.  

 
Figure 18: New View with Filename as Title 

 

Opening Reports 

Once the HP Code Advisor reports have been generated using Generate Reports, you do 

not need to run it again to view the report the next time. 

To view an already generated code advisor report: 

 

1. Right-click the project in the Project Explorer.  

2. Click HP Code Advisor > Open Reports. If the PDB file is generated again, for 

example, through a fresh build, click Generate Reports.  

 

New View opened for the file 
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Figure 19: Open Reports Sub-menu 

 

This opens two new views: Summary and File Summary view.   

 

 

Searching Records 

In an existing HP Code Advisor report, to search records based on Severity or Diagnostic 

Number: 

 

1. Right-click the project in the Project Explorer.  

2. Click HP Code Advisor > Search Records.  
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Figure 20: Search Records sub-menu 

 

3. In the Search Records window, type the search string and select the search type. 

4. Click Search.  

 

 
 

Figure 21: Search records Window 

 

Once a search is run, the search result is displayed in the new view with the records 

matching the search criteria as shown in Figure 22.  
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Figure 22: Search Results Opened in New View 

 

New View of Search results with 

Severity 8 
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Viewing/Changing Code Advisor Properties 

 

To change the Code Advisor configurations entered while creating a project: 

1. Right-click the project in the Project Explorer.  

2. Select HP Code Advisor -> Properties.  

 

 
 

     Figure 23: Code Advisor Properties Window 
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Running the Application 

After successful build, to run your application on HP-UX from the C/C++ Perspective, 

select Run > Run Configurations. 

 

 Figure 24: Execute Binaries created in Remote Standard C/C++ Make Project  
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Run Configuration 

From the left pane of the Run Configuration dialog box, double-click C/C++ Remote. 

This creates a new configuration entry under C/C++ Remote and displays the new 

configuration page on the right pane (Figure 25). 

 

Figure 25: Create Run Configurations  
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On the new configuration page, select the Main  tab. This is where you select your C/C++ 

application and other settings that will impact how your application is run. To customize 

the configuration settings, see Customizing Run and Debug Configurations.  

 

Figure 26: Run Configuration for Car Project  
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Program Selection 

To select a C/C++ application, click Search Project. All executables available in the 

project will be listed. Choose the program you want to run, click Apply , and then Run.  

 

Figure 27: Selecting Created Binary  



              © Copyright 2010 Hewlett-Packard Development Company, L.P.                              

 

32 

Console View 

You can see the application running in the Console view. The Console also displays 

which application is running in the title bar. The view can be configured to display 

different elements (such as user input elements) in different colors. 

 

Figure 28: Console View  
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Run Complete 

The title bar in the Console view displays details when the program has terminated. 

 

Figure 29: Console View after Termination of Program
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Debugging a Remote Application 

You can debug an application by choosing the remote launch configuration. The HP 

Debugger (GDB) is launched remotely on the target system and the current application is 

run in GDB. You can interact with the program's standard input/output/error in the 

command window of the desktop. For GUI applications, an X-server must be running and 

the DISPLAY variable must be set.  

To debug a project remotely on HP-UX integrity / HP 9000 (PA-RISC) server:  

1. Click Run > Debug.  

2. Create the debug configuration. To customize the debug configuration based on 

your requirement, see Run and Debug Configurations.  

3. Click Debug. The debugger starts and a command window of the desktop opens. 

This command window is the program standard input and output. Do not close 

this command window.  

 

 
 

Figure 30: Debug Console View 
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You can also interact with the program standard input/output/error in the command 

window.  

 

 
 

Figure 31: Shows Debug Console View  

 

The command window is terminated when the debugging session ends.  


















































