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Most Frequently asked Question 
 

1. When I was trying to use the debugger to debug on the remote machine, it displayed Launching (55%) 

for a long time on the console window of Eclipse and finally ended with the following error: "Error 

creating session:/opt/langtools/bin/gdb: unrecognized option -i". Why am I getting this behavior? 

  

This behavior may be because an incorrect version of gdb is installed on the remote HP-UX machine. 

Check the version of gdb installed on the remote HP-UX system by typing the following command at 

the command prompt: 

 

HP-UX command prompt> /opt/langtools/bin/gdb –version 

 

If the version installed is less than 6.0, the debugger might not work and the above error will be 

displayed. The gdb version installed on the remote system must be 6.0 or above. If you already have 

gdb version 6.0 or above installed on the remote HP-UX machine and are still receiving the same error, 

mail eclipse-plugins@lists.hp.com with the .log file from the following location: 

 

..\eclipse\workspace\.metadata folder 

 
 

 

2. What does the HP-UX Development Environment for Eclipse do? 

 

The HP-UX Development Environment for Eclipse (HP-UX DEE) allows you to create, edit, and 

perform a Program Analysis of the C/C++ code on a remote HP-UX machine with the help of an Eclipse 

Integrated Development Environment (IDE) that is hosted on a Windows or a Linux machine. The HP-

UX DEE also provides you the ability to compile, run, debug, and memory debug code on the remote 

HP-UX system. The HP-UX DEE user interface displays error messages, provides interactions, and has 

fully-featured graphics which take advantage of the Eclipse IDE on a Windows or Linux system. The 

processing power needed for building, running, and debugging your C/C++ program is provided by the 

remote HP-UX machine (HP Integrity or HP PA-RISC). 

 

3. What are the features supported by the HP-UX Development Environment for Eclipse? 

 

HP-UX Development Environment for Eclipse 4.0.0 includes the following features: 

 

 Remote C/C++ project creation wizard 

 Source file editor 

 Remote build 

 Remote run 

 Remote debug 

 Memory debug 

 Static Analysis of code using Code Advisor 
 

4. How is the HP-UX Development Environment for Eclipse licensed? 

 

See the license file, HP_License.htm, available in the folder: <ECLIPSE_HOME>\plug-

ins\com.hp.cdt.remote.doc.user_X.X.X 

 

5. Which operating systems are supported by the HP-UX Development Environment for Eclipse? 

 

Currently, the plug-in is certified for Windows XP, Red Hat Linux, and SUSE Linux as the local 

desktop machine and will work with HP-UX 11i v2 and later versions on the remote HP Integrity or HP 

9000 (PA-RISC) server machines. 

 

6. With which versions of HP-UX compilers and debuggers are the HP-UX Development Environment 

for Eclipse (HP-UX DEE) supported? 

General 

mailto:eclipse-plugins@lists.hp.com


 

© Copyright 2010 Hewlett-Packard Development Company, L.P. 
6 

 

The HP-UX DEE is supported by: 

 

 HP GDB (version 6.1): http://www.hp.com/go/wdb 

 HP aCC (version 06.25.01 for IA /03.90 for PA-RISC): http://www.hp.com/go/c++ 

      

7. How do I ask questions, report a bug, or request a feature in the HP-UX Development Environment 

for Eclipse (HP-UX DEE)? 

 

On the Technical support section of the HP-UX DEE webpage (www.hp.com/go/eclipse-

remotedevplug-in), click Request help or report problems with HP-UX Development Environment 

for Eclipse. On the resultant page, fill in your details, the issues faced, and click Submit.   

 

Note: 

1. You must mention the procedure step-by-step to reproduce the issues faced.  

2. Remember to attach screen shots and logs to facilitate resolution of the issue. 

 

8. Where do I find more information about the HP-UX Development Environment for Eclipse? 

 

The online help is integrated in the Eclipse IDE. To access the Help file: from the menu bar, select 

Help > Help Contents > HP-UX Development for Eclipse User Guide. 

 

9. How will I know if the network connection is lost while I am building or debugging a program? 

 

The rsh protocol in Red Hat Linux and SUSE Linux does not have a timeout if the network connection 

is lost during the middle of an operation. The rsh process restores its operation when the network is 

restored. Hence, there is no sure way to know if the network connection is lost during the middle of an 

operation. 

 

10. The default fonts in the Eclipse editor in SUSE Linux are not readable. How can I change the fonts? 

         

  You can change the fonts in Windows -> Preferences -> General -> Appearance -> Colors and Fonts. 

See Figure 1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1: Changing Colors and Font

http://www.hp.com/go/wdb
http://www.hp.com/go/c++
http://www.hp.com/go/eclipse-remotedevplugin
http://www.hp.com/go/eclipse-remotedevplugin
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11. Ctrl-M (^M) characters appear when I edit project files. How can I get rid of these ctrl-M (^M) 

Characters? 

 

Follow the steps below to remove the ^M character: 

 

 Open a file in the editor. 

 From the menu bar, select File > Convert Line Delimiters To. 

 Select the delimiters to which you want to convert the file to (one of Windows: CRLF, UNIX: LF, 

MacOS 9: CR) 

 

Note: 

You can also apply these conversions to multiple files, whole folders, or projects that are selected in the 

Package Explorer or in the Navigator. 

 

To change the line delimiters used for new files: 

 

 Set the workspace default (Window > Preferences > General > Workspace > New text file line 

delimiter), or 

 Set the project-specific default (Context menu > Properties > Resource > New text file line 

delimiter) 

 

12. I get out of memory exceptions while using Eclipse or the memory performance is not good. How can 

I improve this? 

 

To improve the memory performance with Eclipse, specify a maximum heap size as a command line 

argument to Eclipse, as shown below. You can change 512 to 1024, or another figure, based on your 

requirement. 

 

           eclipse -vmargs -Xmx512M    (for Windows) 

          ./eclipse –vmargs –Xmx512M  (for Linux) 

 

13. After installing the plug-in, I restarted Eclipse but could not view the added plug-in information in 

the Plug-in-details under the Help tab. How can I update the plug-in details? 

 

After installing any new plug-ins, you must restart your workbench for changes to take effect. Make sure 

you add -clean to your command line when you restart your Eclipse workbench (eclipse -

clean). This will ensure that your Eclipse plug-in configuration is up to date. 

 

14. What are the different protocols which I can use to connect to remote system? 

 

For Windows, you can use either the osrlogin (uses rsh as default) or the ssh protocol. 

For Linux, you can use either the rsh(default) or ssh protocol. 

 

15. How do I use ssh as a protocol? 

      

As a prerequisite for using ssh as a protocol, you need to create a passwordless ssh connection from 

the local system (Windows, Linux) to the remote HP-UX (IPF/PA) system. For Windows systems, you 

must have any windowing client such as cygwin, for ssh.exe to be available on the Windows box. 

For more information, see the HP_Remotedev_SSH_SetUp at www.hp.com/go/eclipse-remotedevplugin. 

 

For Windows: To use ssh as the protocol, follow these steps: 

 

 Go to the plug-ins folder of Eclipse. 

 Open the com.hp.cdt.remote.debug.mi_X.X.X folder. 

 Change the value of <protocolToUseWindows> to ssh in the 

ProjectResources.properties file. 

 Write the correct path where ssh is available on the Windows system as a value of the 

<sshForWindows> variable. 

 From the command prompt, provide the eclipse –clean command to restart Eclipse for 

http://www.hp.com/go/eclipse-remotedevplugin
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the changes to take effect. 

 

For Linux: To use ssh as the protocol, follow these steps: 

 

 Go to plug-ins folder of Eclipse. 

 Open the com.hp.cdt.remote.debug.mi_X.X.X folder. 

 Change the value of <protocolToUseLinux> to ssh in the 

ProjectResources.properties file. 

 Write the correct path where ssh is available on Linux system as a value of the 

<sshForLinux> variable. 

 From the command prompt, provide the eclipse –clean command to restart Eclipse for 

the changes to take effect.  

  

16. Which documents are available for this plug-in? 

 

All the related documentation is present at www.hp.com/go/eclipse-remotedevplugin . 
 

 

17. How do I create a remote C/C++ project? 

 

See the online help by clicking Help > Help Contents > HP-UX Development Environment for 

Eclipse User Guide > Tasks > Creating a remote project. 

 

18. Why remote projects are called Remote Standard Make C++ Project and Remote Standard Make C 

Project? 

 

The C/C++ Development Toolkit (CDT) supports Managed Make and Standard Make projects. When 

you do not have a makefile and do not want to write one, the Managed Make feature can generate one 

for you. When you have a makefile and do not want to generate a make file, select the Standard Make 

feature. Currently, HP-UX Development Environment for Eclipse supports only Standard Make projects. 

 

19. What is a CIFS mount? 

 

The Common Internet File System (CIFS) for HP-UX integrates UNIX with the Microsoft Windows 

environment by providing remote file sharing and authentication services between HP-UX and Windows 

systems. The HP CIFS server allows the Microsoft Windows operating system to access the HP-UX file 

system. The CIFS products use Microsoft's CIFS, which is the standard networking protocol in 

Microsoft Windows operating systems. 

 

For more information, see: 

http://h20293.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=B8725AA 

 

The CIFS mount is used only for Windows systems. The mount command is used for the Red Hat and 

SUSE Linux systems. 

 

20. How do I preserve case in a SAMBA configuration? 

 

If you have to preserve a case between the HP Integrity / HP 9000 (PA-RISC) server and Windows, set 

the following options in the samba configuration file: 

 

            short preserve case = No 

            preserve case = yes 

            case sensitive = yes 

 

Restart SAMBA after setting the above options. 

 

For more information, see the following article: 

        http://docs.hp.com/en/4504/HPCIFSCaseSensitivity.pdf 

 

Remote C/C++ Project Creation 

http://www.hp.com/go/eclipse-remotedevplugin
http://h20293.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=B8725AA
http://docs.hp.com/en/4504/HPCIFSCaseSensitivity.pdf
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21. Which setup do I need to configure to add standard include directories to remote projects? 

 

If you are using Windows, no configuration is required. If you are using a Linux box, complete these 

steps: 

1. Add the following entry to /etc/auto.master: 

/net/<hostname>/etc/auto.net 

2. Add the following entry to /etc/auto.net 

* -fstype=nfs <hostname>:/& 

<hostname> can be in the format opal.ind.hp.com, santhey.ind.hp.com, and so on. 

 

The directories containing standard includes, /usr and /opt, must be exported in the HP-UX box 

(using the /etc/exports file). For example: 

/usr -rw=<target_linux_mc> 

 

To export directories from the HP-UX box, run the exportfs –a command. You must have root 

permissions to perform this command. The standard include directories can now be accessed as 

/net/<hostname>/usr. 

 

To re-mount the exported directories on a Linux box, run the following command: 

/etc/init.d/autofs restart 

 

22. When are standard includes added? 

 

The standard include directories are added during the remote C/C++ project creation. These standard 

include directories are assumed to be at /usr, /usr/include, and 

/opt/aCC/include_std/iostream_compat. 

 

23. Can I add include directories from the remote HP-UX box to my project? 

 

Yes. To add standard include directories from the remote HP-UX box to your project: 

 

1. Right-click Project and select Properties. 

2. Go to the C/C++ Include Paths & Symbols tab and click Add External Include Path.  

3. Specify the path of the include directory on the remote system, such as /opt/aCC/include. 

Ensure that the remote path is in the above format, starting with a slash (/). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

    Figure 2: Adding Include Paths and Symbols 
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24. Can I add include directories on a local system to the project? 

 

For Windows, it is possible to add include directories on a local system to the project. However, on 

Linux this is not supported. 

 

25. What are .RemoteIncludeLinks directories that are being created for my remote projects? 

 

By default, the standard include directories from the HP-UX box are added to remote projects. For this, 

links are created to these directories, which can be accessed on a local system. All these symbolic links 

are present in the .RemoteIncludeLinks folder. 

 

26. How can I handle the “EUC-JP” Locale in Eclipse? 

 

Add -Dfile.encoding=EUC-JP to the eclipse.ini file present under the root folder of the Eclipse 

installation. 

 

27. Which login shells do the HP-UX Development Environment for support? 

 

Currently, the HP-UX Development Environment for Eclipse supports sh and ksh only. 

 

28. When I click “Test Connection…” with ssh as protocol, I get a NullPointerException Error. Why am 

I getting this error message? 
 
 The error message could because of the following reasons: 

 cygwin is not installed. 
 incorrect path of ssh in the ProjectResources.properties file. 

 
 
 

 

29. What tools do I need to run the HP-UX Development Environment for Eclipse? 

 

The following software must be installed on your system: 

 

On the Local Windows System 

 

 Windows XP 

 JDK/JRE 1.6.0_xx (http://java.sun.com/javase/downloads/index.jsp) 

 Eclipse 3.6.x (http://eclipse.org/downloads/index.php) 

 

On the Local Linux System 

 

 Red Hat Enterprise Linux AS 4 (Intel x86 GTK) or SUSE Linux ES 9 (Intel x86 GTK) 

 JDK/JRE 1.6.0_xx (http://java.sun.com/javase/downloads/index.jsp) 

 Remote shell (rsh) must be enabled in your Linux installation 

 Eclipse 3.6.x (http://eclipse.org/downloads/index.php) 

 

On the Remote HP Integrity (Itanium / PA-RISC) Server 

 

 HP-UX operating system version 11i v2 and later 

 HP GDB (version 6.1) http://www.hp.com/go/wdb 

 HP aCC (version 6.25.01 for IA / 3.90 for PA-RISC) http://www.hp.com/go/c++ 

 CIFS server (Samba) 

http://h20293.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=B8725AA 

 

Note: For Linux, the CIFS Server (Samba) is not required. The file structure from the HP Integrity / HP 

PA-RISC server is exported to a Linux system by using the mount (NFS) command. 

 

Compilers and Other Tools 

http://java.sun.com/javase/downloads/index.jsp
http://eclipse.org/downloads/index.php
http://java.sun.com/javase/downloads/index.jsp
http://www.hp.com/go/wdb
http://www.hp.com/go/c++
http://h20293.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=B8725AA
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30. How can I generate HP Code Advisor PDB using HP-UX Development Environment for Eclipse? 

 

Specify the appropriate Code Advisor command, for make targets in the makefile. When these targets 

are built, they will use the features of Code Advisor. A sample target specification is given below: 

 

pdb: 

/opt/cadvise/bin/cadvise +wall -pdb xyz.pdb -tee /opt/aCC/bin/aCC -c -

g demo.c 

/opt/cadvise/bin/cadvise +wall -pdb xyz.pdb -tee /opt/aCC/bin/aCC –o 

demo demo.o 

 

 

31. From where can I download the Eclipse Plug-in for HP Code Advisor? 

 
There is no separate Code Advisor plug-in. You need to download the HP-UX Development 

Environment for Eclipse, version X.X.X (www.hp.com/go/eclipse-remotedevplug-in), which contains 

the Code Advisor feature. 
 
 

32. Why is the diagnostic message in detailed view not displayed completely?  

 

JDK/JRE version 1.6.0_xx might not be installed; install the JDK.JRE version 1.6.0_xx. 

 

33. Is it possible to change the PDB location after creating the remote project? 

 

Yes. To change the location after creating the remote project, right-click Project and select Properties. 

Then select HP Code Advisor (or) right-click Project and select HP Code Advisor and select 

Properties. 

 

34. Is it possible to install only the Code Advisor plug-in separately? 

 
No.  

 

35. How can I view the Code Advise detailed report? 

 

From the menu bar, select Window > Show view > Other. In the HP Code Advisor category, select 

Detailed. This will open a new view, with a detailed report of all records. 

 

36. Where do I find more information about the HP Code Advisor plug-in? 

 

The integrated online help is available in the Eclipse IDE. From the menu bar, select Help > Help 

Contents > HP-UX Development Environment for Eclipse User Guide.  

 

37. How can I configure Code Advisor for my remote project? 

 

To use Code Advisor for your remote project: 

 

1. Generate the PDB for your project.  

2. Right-click Project and select Properties.  

3. Go to HP Code Advisor and enter the PDB location and code advisor location.  

4. Click Apply and OK.  

5. For generating reports, right-click Project and select HP Code Advisor > Generate Reports.  

 

38. I have generated the PDB and specified the correct PDB path in the HP Code Advisor settings. 

However, when I click Generate Reports, the following message is displayed: “Reports not found. TO 

view the reports, generate reports properly.” Why am I getting the message? 

 

This may be because your PDB does not contain any records to display. This message is displayed in the 

following situations: 

1. If you try to open reports without generating them. 

http://www.hp.com/go/eclipse-remotedevplugin
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2. If your PDB does not contain any records in it. 

 

 
 

 
 

39.  What is Source Directory? 

 

This is the root directory where your source files are located in remote HP-UX machine. The make file 

and executables (binaries) are determined using this source directory. 

 

40. How does the HP-UX Development for Eclipse identify where my makefile is located on the remote 

machine? 

 

Currently, the HP-UX Development Environment for Eclipse assumes that your make file is available in 

the source directory you specified when creating the project. 

 

41. Does a local build also occur when using the HP-UX Development Environment for Eclipse? 

 

No. 

 

42. How do I build a project without a target name? 

 

Create a new make target without specifying a name in the Make Target field as shown in figure 3. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

   Figure 3: Creating a New Make Target 

 

43. Can my make file point to ansic? 

 

The HP-UX Development Environment for Eclipse supports only aCC. If the make file does not point to 

aCC, it is likely that the problem window will not report all the errors encountered by the compiler. HP 

recommends that you use aCC instead of ansic. 

 

44. When I click PATH on the Environment tab, I do not see all my paths? 

 

For security reasons, rsh does not source all the environments. Hence, you will not see all your paths. 

Building C/C++ Projects 
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You can manually add these paths on the Environment tab. 
 
 

 

45. Where can I see the program input and output of the program being debugged? 

 

The debugger process opens a command window that displays the program’s standard input and output. 

On Linux, XTerm is the program’s standard input and output. 

 

46. Can I close the command window/XTerm while debugging a C/C++ project? 

 

The command window is the program’s standard input and output and this window should not be closed 

while debugging C/C++ projects. 

 

47. How do I get a snapshot of Registers while debugging? 

 

Click Window->Show View->Registers. 

 

48. How do I get a snapshot of the Shared libraries while debugging? 

 

Click Window->Show View->Modules. 

 

49. What does “register grouping” mean? 

 

The Registers view now supports the concept of register groups, allowing users to define a collection of 

registers that are relevant for their particular debugging environment. The user can disable Main and 

define a new group that has a smaller number of registers for better performance. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    Figure 4: Register Grouping 

 

50. Why do I see directories called “.test_<number>” in my home directory on the HP Integrity / HP 

9000 (PA-RISC) Server? 

 

They are temporary directories that are being created by our plug-in. These directories will be removed 

when the debugger terminates successfully. 

 

51. Can I enhance the performance of the remote debugger in Windows? 

Debugging C/C++ Projects 
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Yes, the performance of the remote debugger can be enhanced in Windows by adding a registry entry as 

specified in the URL: 

http://support.microsoft.com/default.aspx?scid=kb;en-us;823764 

 

52. Why do I not see the values for floating point registers for HP Integrity, during debugging? 

 

This is a known issue, which occurs with GDB on the HP Integrity platform. A workaround for this 

issue is given in the next answer. 

 

53. Is there a way I can see values for floating point registers for HP Integrity, during debugging? 

 

Yes. Go to the Debugger Process console window and type the info all-registers command. This 

displays the values for all registers, including the floating point registers. 

 

54. How can I use gdb CLI commands through HP-UX Development Environment for Eclipse? 

 

During a debug session, go to the Debugger Process console window. The CLI commands can be 

specified here. Their output will also be displayed in this window. 
 
 
 

 

 

55. Why do I see the .cdtproject, .project and hpremotedevstore files in my folder even after I delete the 

project? 

 

These files are metadata files that are used by Eclipse. 

 
 

Deleting C/C++ Projects 


